Tudo sobre Marketing e Empreendedorismo

Vulnerabilidades descobertas em cinco plugins WooCommerce do WordPress

Vulnerabilidades são descobertas em cinco plugins WooCommerce WordPress com mais de 135.000 instalações. Portanto, veja quais foram as falhas de vulnerabilidade que o núcleo VND do governo norte-americano detectou nos plugins.

Aplicativo do WordPress aberto em tablet branco com caneta pra o mesmo sobre a tela
Para fugir de vulnerabilidades nos plugins do WooCommerce WordPress, atualize tudo que for possível para as novas versões. Imagem de Souvik Banerjee em Unsplash

Vulnerabilidades no WooCommerce

O National Vulnerability Database (NVD) do governo dos EUA publicou avisos de vulnerabilidades em cinco plugins WooCommerce WordPress que afetam mais de 135.000 instalações.

Muitas destas vulnerabilidades variam em gravidades que vão até o nível Crítica e são classificadas como 9,8 em uma escala de 1 a 10. Cada uma, por sua vez, recebeu um número de identidade CVE (Common Vulnerabilities and Exposures) dado às questões que foram descobertas. Caso você use ou não o e-commerce do WordPress, veja mais detalhes a seguir:

1. Exportação avançada de pedidos para WooCommerce

O plugin Advanced Order Export for WooCommerce, instalado em mais de 100.000 sites, é vulnerável a um ataque Cross-Site Request Forgery (CSRF).

Uma vulnerabilidade Cross-Site Request Forgery (CSRF) surge de uma falha em um plug-in do site que permite a um invasor enganar um usuário do domínio para que execute uma ação não intencional.

Os navegadores de sites, de modo geral, contêm cookies que informam a um site que um usuário está registrado e conectado. Um invasor pode assumir os níveis de privilégio de um administrador. Isso dá ao invasor acesso total a um site, expõe informações confidenciais do cliente e assim por diante.

Essa é uma das vulnerabilidades mais específicas e que pode levar a um download de arquivos de exportação. A descrição dessa falha de segurança não descreve qual arquivo pode ser baixado por um invasor.

Dado que o objetivo do plug-in é exportar dados de pedidos do WooCommerce, pode ser razoável supor que os dados de pedidos sejam o tipo de arquivo que um invasor pode acessar.

A descrição oficial da vulnerabilidade:

“Vulnerabilidade Cross-Site Request Forgery (CSRF) no plugin Advanced Order Export For WooCommerce <= 3.3.2 no WordPress levando ao download do arquivo de exportação.”

A vulnerabilidade afeta todas as versões do plugin Advanced Order Export for WooCommerce que são inferiores ou iguais à versão 3.3.2. Assim, o changelog oficial do plugin observa que a vulnerabilidade foi corrigida na versão 3.3.3.

2. Preços dinâmicos avançados para WooCommerce

O segundo plug-in afetado é o plug-in Advanced Dynamic Pricing para WooCommerce, instalado em mais de 20.000 sites. Este plugin foi descoberto para ter duas vulnerabilidades Cross-Site Request Forgery (CSRF) que afetam todas as versões do plugin anteriores a 4.1.6.

O objetivo do plug-in é tornar mais fácil para os comerciantes criar regras de desconto e preços. A primeira vulnerabilidade (CVE-2022-43488) pode levar a uma “migração de tipo de regra”.

Isso é um pouco vago. Talvez possa ser feita uma suposição de que a vulnerabilidade pode ter algo a ver com a capacidade de alterar as regras de preços. Veja a descrição oficial fornecida no NVD:

“Vulnerabilidade Cross-Site Request Forgery (CSRF) no plugin Advanced Dynamic Pricing for WooCommerce <= 4.1.5 no WordPress, levando à migração do tipo de regra.”

O NVD atribuiu ainda à segunda vulnerabilidade CSRF no plugin Advanced Dynamic Pricing for WooCommerce um número CVE, CVE-2022-43491. A descrição oficial do NVD da vulnerabilidade é:

“Vulnerabilidade Cross-Site Request Forgery (CSRF) no plugin Advanced Dynamic Pricing for WooCommerce <= 4.1.5 no WordPress levando à importação de configurações do plugin.”

As notas oficiais do changelog do plugin:

“Changelog – 4.1.6 – 2022-10-26

Corrigimos algumas vulnerabilidades de CSRF e de controle de acesso quebrado”

3. Cupons avançados para plugin de cupons WooCommerce

O terceiro plugin afetado, Advanced Coupons for WooCommerce Coupons, tem mais de 10.000 instalações. O problema descoberto neste plugin também é uma vulnerabilidade CSRF e afeta todas as versões anteriores a 4.5.01.

O changelog do plugin chama o patch de correção de bug. Mas, o que isso significa afinal?

“4.5.0.1

Correção de Bug: O aviso de início dispensa a solicitação AJAX não tem valor nonce.”

A descrição oficial do NVD é:

“Vulnerabilidade Cross-Site Request Forgery (CSRF) no plugin Advanced Coupons for WooCommerce Coupons <= 4.5 no WordPress levando à dispensa de aviso.”

4. Dropshipping WooCommerce por OPMC – Crítico

O quarto software afetado é o plugin WooCommerce Dropshipping by OPMC, que possui mais de 3.000 instalações. As versões deste plug-in anteriores à versão 4.4 contêm uma vulnerabilidade de injeção SQL não autenticada classificada como 9.8 (em uma escala de 1 a 10) e rotulada como Crítica.

Em geral, uma vulnerabilidade de injeção de SQL permite que um invasor manipule o banco de dados do WordPress e assuma permissões de nível de administrador, faça alterações no banco de dados, apague o banco de dados ou até mesmo baixe dados confidenciais.

O NVD descreve essa vulnerabilidade específica de plug-in dessa forma:

“O plug-in WooCommerce Dropshipping WordPress anterior à versão 4.4 não limpa adequadamente e escapa um parâmetro antes de usá-lo em uma instrução SQL por meio de um ponto de extremidade REST disponível para usuários não autenticados, levando a uma injeção de SQL.”

5. Preços baseados em funções para WooCommerce

O plugin Role Based Pricing for WooCommerce tem duas vulnerabilidades Cross-Site Request Forgery (CSRF). Existem 2.000 instalações deste plugin.

Conforme mencionado sobre outro plugin, uma vulnerabilidade CSRF geralmente envolve um invasor enganando um administrador ou outro usuário para clicar em um link ou realizar alguma outra ação. Isso pode fazer com que o invasor obtenha os níveis de permissão do site do usuário.

Esta vulnerabilidade é classificada como 8,8, que é muito alta. Por isso, a descrição do NVD da primeira vulnerabilidade adverte:

“O plug-in Role Based Pricing for WooCommerce WordPress antes de 1.6.2 não possui autorização e verificações CSRF adequadas e não valida o upload de arquivos, permitindo que qualquer usuário autenticado, como assinante, faça upload de arquivos arbitrários, como PHP”

A seguir está a descrição oficial do NVD da segunda vulnerabilidade:

“O plug-in Role Based Pricing for WooCommerce WordPress antes de 1.6.3 não possui autorização e verificações CSRF adequadas, bem como não valida o caminho fornecido pela entrada do usuário, permitindo que qualquer usuário autenticado, como o assinante, execute ataques de desserialização PHAR quando eles podem fazer upload de um arquivo e uma cadeia de gadgets adequada está presente no blog”

O registro de alterações oficial do plugin WooCommerce WordPress de Preços Baseados na Função informa que o plugin está totalmente corrigido na versão 1.6.2:

“Changelog 2022-10-01 – versão 1.6.2

* Corrigida a vulnerabilidade de upload de arquivo arbitrário.

* Corrigido o problema de verificação de nonce ajax.”

Como agir a partir de agora?

É considerado uma boa prática atualizar todos os plugins vulneráveis. Também é uma prática recomendada fazer backup do site antes de fazer qualquer atualização de plug-in e (se possível) preparar o site e testar o plug-in antes de atualizar.

Fonte: SearchEngineJournal.com

Seja o primeiro a ser notificado, sempre que um novo artigo ser publicado

Deixe uma resposta

Usamos cookies para melhorar sua experiência neste site. Ao continuar no site, você concorda com essas condições. Sim Mais detalhes